Phone Carrier - possible issue with inbound/outbound calls via JFK data center
Incident Report for MedicTek System Status
Resolved
Monitoring is complete. We consider the matter resolved.
Posted Nov 16, 2023 - 10:57 EST
Monitoring
Carrier has identified and fixed problem, we are continuing to monitor. Please report any phone call anomalies to us at 800-260-9910 or by sending an e-mail with brief description to helpdesk@medictek.com.
Posted Nov 15, 2023 - 15:33 EST
Identified
MedicTek has been notified by our national phone carrier that some inbound or outbound calls may be affected by a partial outage at the JFK data center. If you are experiencing any phone call problems at all, please notify us and we will switch you to the back-up routing for all calls - which only takes a few seconds. Please call us at 800-260-9910 option 1 or send an e-mail to helpdesk@medictek.com with any details you may be able to share.
Posted Nov 15, 2023 - 11:06 EST
This incident affected: 3rd Party (Phone Carrier VOIP).