Inbound Microsoft 365 mail may be delayed
Incident Report for MedicTek System Status
Resolved
Per Microsoft, this issue should be resolved.
Posted Jul 19, 2023 - 11:00 EDT
Identified
Inbound and outbound delivery may be delayed 15 minutes or more. Microsoft is aware of the problem and is implementing a solution.
Posted Jul 18, 2023 - 18:34 EDT
This incident affected: 3rd Party (Microsoft 365).