DFW Call Failure Incident
Incident Report for MedicTek System Status
Resolved
This incident has been resolved.
Posted Jan 20, 2022 - 15:57 EST
Monitoring
New incident: Monitoring

For a brief period of time between noon-2PM Eastern, a small sub-section of customers may have experienced unexpected call failures in the DFW data center. At this time calls are processing as expected and we continue to monitor for ongoing stability. INBOUND/OUTBOUND
Posted Jan 20, 2022 - 15:12 EST
This incident affected: 3rd Party (Phone Carrier VOIP).