Possible "DIAL DELAY" noted from carrier
Incident Report for MedicTek System Status
Resolved
Our carrier has notified us the incident has been resolved.
Posted Feb 17, 2024 - 22:39 EST
Investigating
We have been notified from our phone carrier that some calls may experience a Post-dial delay (PDD). The PDD is the measurement of how long it takes for a calling party to hear a ringback tone after initiating a call. They are actively working on the issue and we will post an update when available. Feel free to notify us at helpdesk@medictek.com if service doesn't connect after a 15 second max delay.
Posted Feb 17, 2024 - 16:51 EST
This incident affected: MedicTek Owned (Phone System) and 3rd Party (Phone Carrier VOIP).