Outbound calls and delays
Incident Report for MedicTek System Status
Resolved
After additional monitoring, it appears the carrier resolved the issue. If you experience any call problems, please e-mail us at helpdesk@medictek.com - thank you!
Posted Jul 07, 2023 - 12:36 EDT
Monitoring
Our national carrier discovered a problem on 7/6/23 with some outbound calls and delays in connections when calls were placed. Overnight, emergency maintenance was performed on their end and they indicate the issue is resolved. We will monitor performance. If you experience any outbound call issues, please open a ticket at helpdesk@medictek.com so we can relay to the carrier. Thank you.
Posted Jul 07, 2023 - 08:56 EDT
This incident affected: 3rd Party (Phone Carrier VOIP).