E-Mail management / Malware hosting issues
Incident Report for MedicTek System Status
Resolved
This incident appears to be resolved by vendor.
Posted Jun 25, 2022 - 09:21 EDT
Monitoring
A fix has been implemented by vendor and we are monitoring results.
Posted Jun 24, 2022 - 17:38 EDT
Investigating
We have reported an issue to the vendor about the administrator portal being down. We are unaware if this will have additional effect on e-mail. At present, we are unable to add/change/edit e-mail or Microsoft 365 accounts.
Posted Jun 24, 2022 - 15:50 EDT
This incident affected: Vendor Hosted Applications (AppRiver E-Mail Anti-SPAM Anti-Malware Hosted Platform).