Outlook web-version issues
Incident Report for MedicTek System Status
Resolved
We believe this issue is not wide spread and/or has been resolved.
Posted Jun 01, 2022 - 10:51 EDT
Investigating
From Microsoft: Some users may be able to access Outlook on the web but are unable to access various features. In addition to the Outlook on the web impact, admins may be intermittently unable to access the admin center.
Posted Jun 01, 2022 - 05:41 EDT
This incident affected: 3rd Party (Microsoft 365).