Microsoft Issue with Outlook inboxes (Exchange Online)
Incident Report for MedicTek System Status
Resolved
The Microsoft 365 Outlook issue with e-mail should be resolved at this time. Please call our support office at 800-260-9910 if you are still experiencing difficulty with e-mail.
Posted Jul 18, 2022 - 15:53 EDT
Identified
Microsoft has released the following: Users may be unable to access Exchange Online. Microsoft has identified that a network router was performing below acceptable thresholds. User have been re-routed to alternate devices and monitoring telemetry indicates that the service has recovered. We've entered a period of extended monitoring to ensure the issue is resolved. Scope of impact: This issue could impact any user attempting to access Exchange Online and are located in the North-eastern United States and surrounding geographical regions.

Start time: Monday, July 18, 2022, at 1:02 PM UTC
Next update by: Monday, July 18, 2022, at 4:30 PM UTC

Thank you,
The Microsoft team
Jul 18, 11:05 CDT
Update - Exchange Online service alert

Incident information
Title: Unable to access Exchange Online
ID: EX401976

Status
Service Degradation

Affected Services
Exchange Online, Exchange Online
Posted Jul 18, 2022 - 12:24 EDT
This incident affected: 3rd Party (Microsoft 365).