Microsoft 365 Outlook issues
Incident Report for MedicTek System Status
Resolved
This incident has been resolved.
Posted Jun 05, 2023 - 17:01 EDT
Update
The issue appears to be resolved - we will continue to monitor, but all systems are operational at this time.
Posted Jun 05, 2023 - 17:00 EDT
Update
Some Outlook access has returned to normal - we will continue to monitor.
Posted Jun 05, 2023 - 11:01 EDT
Investigating
We have noted what appears to be a major outage with Microsoft 365 and Outlook. Both the web and application versions of Outlook began having trouble around 10:45AM Eastern. We will continue to investigate and post updates as they become available.
Posted Jun 05, 2023 - 10:54 EDT
This incident affected: 3rd Party (Microsoft 365).