Phone Carrier Issues
Incident Report for MedicTek System Status
Resolved
This issue appears to be resolved, if you experience any problems, please call 800-260-9910.
Posted May 25, 2022 - 10:33 EDT
Investigating
We were notified around 7:10AM Eastern from our phone carrier that various issues with failed calls is being investigated. If you experience any issues, please send an e-mail to helpdesk@medictek.com with the time of the call and a brief description what happened so we may forward it along. Thank you for your patience.
Posted May 25, 2022 - 07:20 EDT
This incident affected: 3rd Party (Phone Carrier VOIP).