The issue has been resolved and we have confirmed with testing that no other calls have come through with from the carrier since around 10:00AM Eastern Time. Thank you for your patience.
Posted Mar 25, 2025 - 10:40 EDT
Investigating
We have informed our VOIP back-end carrier that many CALLERID names are being passed through our system with the phone number and not the CALLERID name. The name is coming through as on many of these calls. Please be aware that inbound calls should still function normally and we are investigating the issue. If you experience any other issues, please feel free to call us or open a ticket by e-mailing helpdesk@medictek.com with any relevant details you can provide.
Posted Mar 25, 2025 - 09:41 EDT
This incident affected: MedicTek Owned (Phone System) and 3rd Party (Phone Carrier VOIP).